Feature #684

Allow to specify whether an R script is expected to produce a text or an image

Added by Olivier Mehani about 2 years ago. Updated 11 months ago.

Status:ClosedStart date:15/03/2012
Priority:NormalDue date:
Assignee:Christoph Dwertmann% Done:

0%

Category:-
Target version:-
Sprint:Backlog

Description

Not all R scripts generate images. oml.R should be extended with a function specifying what the portal should expect (a PNG graph, a text output, ...) and display the relevant one by default.

For text-by-default, it would be good if the initial R header, up and not including the first command of the user script, were hidden by default, but displayable.

A prime example of the problem is at http://ireel.npc.nicta.com.au/issues/866#note-1 : no graph is generated, but text output is valuable. However, asking to display R output also shows all the R header, which is a bit useless when the script is not incorrect, and only its output is valuable to the researcher.

History

#1 Updated by Olivier Mehani about 2 years ago

  • Assignee set to Christoph Dwertmann

#2 Updated by Guillaume Jourjon 11 months ago

  • Sprint set to Backlog

#3 Updated by Guillaume Jourjon 11 months ago

  • Status changed from New to Closed

#4 Updated by Olivier Mehani 11 months ago

Has this been fixed?

--
Olivier Mehani
PGP fingerprint: 4435 CF6A 7C8D DD9B E2DE F5F9 F012 A6E2 98C6 6655

Also available in: Atom PDF